·
Brevo declared incident closed
Resolved
Monitoring
We are monitoring Brevo status, mails seems now been sent
Investigating
Brevo encounters problem on their platform impacting Procertif email sent
Source : https://status.brevo.com/